Home
Download
Screenshots

Wiki
Plugins
Translations
Developers
Donate

Forums/Help
Contact Us

StrokeIt

Winuae does not recognise Strokeit?

Posted by mclane 
Winuae does not recognise Strokeit?
January 16, 2010 06:34AM
Hi there, hope this is the right section..

I use strokeit a lot and find it helpful in some emulators to shortcut keys, I've never had a problem until now. I use Winuae which is an Amiga emulator for windows but no matter what class or any settings I can see the gesture but it makes no effect.

www.winuae.net

I'm totally stuffed on this one, has anyone got any ideas please?

Btw, using Windows 7 X64, all drivers etc up to date and using latest Strokeit..
Leo
Re: Winuae does not recognise Strokeit?
January 16, 2010 11:07AM
Hello mclane,

File name :
winuae.exe

Works for me ok WinXP sp3

Greetings

Leo
Re: Winuae does not recognise Strokeit?
January 17, 2010 04:03AM
Hi Leo, what version of Winuae are you using please?
Re: Winuae does not recognise Strokeit?
January 17, 2010 04:15AM
Hi again Leo..

I can get strokeit to work with Winuae but not with any keystroke input or hot keys ie I can't make it do anything that is Winuae specific.

Here's what my cfg looks like..

exec=winuae.exe
New Action {
gesture = Right
New Command = keys, keys "[F12_down][F12_up]"
}

With that it should open up the prefs screen for Winuae, does it work for you?

Last totally unrelated question, would you be the same Leo from the Directory Opus forums, him of excellent guides?

I only say it because the same Leo was the guy who got me using Strokeit :)
Leo
Re: Winuae does not recognise Strokeit?
January 17, 2010 09:32AM
Hello mclane,

version 2.0.1

Use this one
winmsg - post message
window by class name: Useless
message id :WM_COMMAND
configuration :wparam: 0x9C4A
eject: 0x9C4D
floppy: wparam: 0x9C4E
reset: 0x9C53


And I am the Leo from strokeit.tk :P

Greetings



Edited 2 time(s). Last edit at 01/18/2010 10:32AM by Leo.
Attachments:
open | download - amiga.zip (5.8 KB)
Re: Winuae does not recognise Strokeit?
January 17, 2010 09:34AM
I've since tried 9.6 strokeit, the same problem..

Thought Win 7's UAC might have been an issues but I had turned it off and disabled virus and firewall stuff (nortons) but still the same..

Strokeit understands global commands like web browser and max min the window while running Winuae but nothing direct for Winuae works here. I tried all class and file types in strokeit and tried just sending un bracketed keystrokes.

No joy under any of those...
Leo
Re: Winuae does not recognise Strokeit?
January 17, 2010 09:55AM
Hello mclane,

Do you tried my WM_COMMAND ?
Re: Winuae does not recognise Strokeit?
January 17, 2010 11:01AM
Hi Leo, just tried the WM Command thing and it worked a treat...


And of course this leads to questions

1. Why does it need this for my setup yet works on yours under XP?

2. How can I learn to do the same thing please as I want to add a reset to a shortcut which is ctrl + alt + Insert + Home.

3. Could you explain what those params are doing in a simple for he dummy way :)

Thank you
Leo
Re: Winuae does not recognise Strokeit?
January 17, 2010 11:17AM
Hello mclane,

1. Window Class to handle Config is not WinUE instead it is class "Useless" for reason ask Author.

2. You need a hotkeyprogram which can handle those WinMsg for example
PowerPro

3. Read the FAQ: [www.tcbmi.com]
Read WinAPI explanation.

Thanks Leo
Re: Winuae does not recognise Strokeit?
January 17, 2010 11:27AM
Thanks, I'll have a look Leo but are there any tutorials re this that you know of ?
Leo
Re: Winuae does not recognise Strokeit?
January 17, 2010 11:47AM
Ok mclane I have google a little bit
[www.cs.binghamton.edu]

cu Leo
Re: Winuae does not recognise Strokeit?
January 17, 2010 12:17PM
Sorry Leo, last bit of help please, I think I'm getting there with Girder but the Strokeit faq says this " Add a command (STRG +A)".

But I'm not sure where this goes or what it exactly means..

I've got to the capture window and captured Winuae but I'm at a loss as to what the above needs me to do and on what window?

Honestly, last bit of help for an old un :)

Thanks Leo
Re: Winuae does not recognise Strokeit?
January 17, 2010 01:58PM
Well, I'm not Leo and I have no idea, what the above should mean, but as far as I know, STRG is the German abbreviation for CTRL :) Therefore you should add a simple hotkey command CTRL+A
Re: Winuae does not recognise Strokeit?
January 18, 2010 01:23AM
Ah Thank you, I thought it was some sort of string type command..Many thanks
Re: Winuae does not recognise Strokeit?
January 18, 2010 07:21AM
Hi Leo, thanks for all the help, I've given up based on my stupidity to be honest..

I loaded up girder and followed both the help re comand grabbing and the FAQ post, for some reason the series of commands it captures do not work as a test, I get an error message re no matches and handles.

I'm following the what I believe are the right instructions, I thought I was getting it right as one capture show an open floppy instruction when I pressed END + F1 which loads a disk in Winuae but when I hit the test button on the list of commands nothing happened.

Nor did I see any thing that reassembled the previous WM_Command thing you sent...

So I gave up, all I wanted to do was make strokeit send a CTRL + ALT + INSERT + HOME string so I could reset the machine with a left command :)

Not sure what I have done wrong but my poor aged brain can't hack it :)
Leo
Re: Winuae does not recognise Strokeit?
January 18, 2010 07:46AM
Hello mclane,

Look at these WM_COMMAND

reset is 9C53
Re: Winuae does not recognise Strokeit?
January 18, 2010 09:48AM
Leo Wrote:
-------------------------------------------------------
> Hello mclane,
>
> Look at these WM_COMMAND
>
> reset is 9C53

Hi again Leo, sorry for bothering you, I tried entering that in several ways but I'm at a loss in total honesty. I think the only way is either to post the whole code to reset the Winuae as you very kindly did with the F12 command

like this

>winmsg - post message
>window by class name: Useless
>message id :WM_COMMAND
>configuration :wparam: 0x9C4A
>eject: 9C4D
>floppy: wparam: 0x9C4E
>reset: 9C53


or either shoot me or me to thank you for all your time and effort to teach me and leave you to get on with less annoying people :)

Either way, thanks...
Leo
Re: Winuae does not recognise Strokeit?
January 18, 2010 10:25AM
Hello mclaine,
I upload picture,

[www.tcbmi.com]

so instead
0x9C4A
0x9C53

cu Leo
Re: Winuae does not recognise Strokeit?
January 18, 2010 10:44AM
Leo, you are a star, also I am annoyed with myself, I had done exactly that when I was messing around but because nothing happened I gave up.

Turns out I had failed to set a gesture for that command hence it did not work...

But yet again many thanks...

Any reason why when I did a command record I never saw 9C53 anywhere in Girder or is that too long a question?

Anyhow, THANK YOU!!!
Leo
Re: Winuae does not recognise Strokeit?
January 18, 2010 01:38PM
Ok mclane if you want to try unhide "Useless" window if you find with this one.

[www.codeproject.com] and try girder again.

cu Leo
Re: Winuae does not recognise Strokeit?
January 19, 2010 11:04AM
Thanks again Leo, I tried it but I'm obviously doing something wrong as I pick the 'Useless window in the command capture, do a capture but the test option just seems to focus the window and does nothing else.

Also the number it gives after the left button bit is not any of the commands you gave me be it hex or decimal...

Thanks for all the help, the commands you have given me are all I need although I don't seem to understand what the 'eject' code does, all the others work brilliantly.

Wish I had you skills but maybe one day :)
Re: Winuae does not recognise Strokeit?
January 24, 2010 09:00AM
Just a last message to you Leo, been using Girder with other utils and it's brilliant. Don't understand why I was having such an issue with Winuae but there you go.

Between girder and Strokeit there's almost nothing I can't do...

For that, many thanks...
Re: Winuae does not recognise Strokeit?
April 05, 2010 11:05AM
Hi Leo, making a mini return to ask one little thing.

It stumped me as to why I could not see the Useless window in Girder, I got the Windows Unhider found the window and made it visible (well it showed it on the task bar.

In Girder I can see the window and if I click on it in Girder I get sometimes a match and sometimes not, I can't use the window finder tool as no visible window comes up for me to point to it.

Is there something I'm doing wrong here that you can see...

This has totally stumped me and it's the only program so far I have had a single issue with. All I want to understand is how to get the hidden Useless window being used in Girder, Windowunhider says it's visible and I can see it only on the task bar...

Sorry to be a pain but it's soo bugging me and bound to be something very simple.

Hopefully you won't mind one last bit of help...
Author:

Your Email:


Subject:


Attachments:
  • Valid attachments: zip, sxp, cfg
  • No file can be larger than 128 KB
  • All files together cannot be larger than 512 KB
  • 4 more file(s) can be attached to this message

Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: